aboutsummaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorEugeniy E. Mikhailov <evgmik@gmail.com>2021-12-12 23:32:52 -0500
committerEugeniy E. Mikhailov <evgmik@gmail.com>2021-12-12 23:32:52 -0500
commite789146f87cc0865972e93704b5d988c333bc190 (patch)
tree8b2d2ba1ac82938e260bc5feacab48fb4e015925 /pyproject.toml
parent7f8954b62f72446954c617ac10fc51a12ea75135 (diff)
downloadqolab-e789146f87cc0865972e93704b5d988c333bc190.tar.gz
qolab-e789146f87cc0865972e93704b5d988c333bc190.zip
update required packages
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml7
1 files changed, 7 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 1dca94c..8def497 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -8,4 +8,11 @@ author = "Eugeniy E. Mikhailov"
author-email = "eemikh@wm.edu"
classifiers = ["License :: OSI Approved :: GNU General Public License v3 or later (GPLv3+)"]
description-file = "README.md"
+requires = [
+ "numpy >=1.19.5",
+ "matplotlib >=3.3.4",
+ "pyvisa >=1.11.3",
+ "scipy >=1.6.0",
+ "pyyaml >=5.3.1",
+]